CC WebBrowser 1.0.0

Started by SamH, Jul 11, 2020, 07:45 pm

Previous topic - Next topic

To Do

HTML tables
0 (0%)
basic CSS
2 (40%)
basic Javascript
3 (60%)
I Frames
0 (0%)
Working Links
0 (0%)
Other (send in replys)
0 (0%)
Nothing
0 (0%)

Total Members Voted: 5

SamH

Jul 11, 2020, 07:45 pm Last Edit: Jul 23, 2020, 02:37 pm by Lemmmy
CC WebBrowser 1.0.0

Hello wonderful Computercraft Forums!
Today I make a wonderful web browser
Currently you can only view single paged websites some may be a mess

No pics , no clicks. No problem!


Website viewed in CC







Website viewed on real browser



Download ?
Code Select
pastebin get 964NZUAU ccbrowser
Bugs ?
Probably a few, however I squashed most of them,
You can help squash them to!

You can support by programming the popular poll options!
And reply with a pastebin or Github link!


Lupus590

I found this tool which will allow you to generate image links that will work with the forum, I've edited your post to do the first one as a proof that it works.

https://sites.google.com/site/gdocs2direct/

SamH


Ocawesome101

Rather important question: does this browser work with any webpage, or just those specifically built for it?

Unrelated, less important question: how long have you been working on this? It looks neat, though the images unfortunately don't load for me on mobile.

QuickMuffin8782

Jul 14, 2020, 01:09 pm #5 Last Edit: Aug 17, 2020, 03:09 pm by QuickMuffin8782
Erm... the images don't show up on my screen. They seem broken again...
It's fixed. That tool sure helps.
GOTTA GO FAST!!!!
Gitlab - COSC - XenusSoft - Hangout

SamH

Just try clicking on the links form me , they are the images

SamH

Wow 1,243 views on Pastebin !

pjals

hi i am T79, bye

Ryoman

This Looks Really Cool But Im Having Trouble Finding Pages That Work Well With This

Ryoman

also i found a bug. trying to load the demo page gives me a 404 error

Ryoman

i also have a suggestion: can you make it so i can load local HTML files? this way i can make somthing thats compatible

Lemmmy

I fixed your images - you were using 'http' instead of 'https' for the URLs

QuickMuffin8782

OOF, looks like your pastebin is broken...
GOTTA GO FAST!!!!
Gitlab - COSC - XenusSoft - Hangout

Lupus590

Quote from: QuickMuffin8782 on Aug 08, 2020, 05:30 amOOF, looks like your pastebin is broken...
Pastebin has been broken for everyone the past couple of days