Started by iJinxIt, Apr 23, 2021, 09:12 pm
Quote from: Kaikaku on Apr 24, 2021, 09:38 pmLooks pretty nice and I like the use of % :)Here're a few suggestions:Readability: You could add comments after '--' e.g., -- put coal in slot 1 and torches in slot 2Order of functions: You're using in minenGehen() the function zweige(), which is declared after minenGehen(). This could through an error, as at the beginning lua is not aware of which functions come later in the code.Table: I'd probably put the long if-statement in dropWaste() in a table/array. This way you could loop through all items. Cleaner and easier to maintain.Fun fact: In my first programs (not CC) I mixed also German function names with English commands. It got confusing fairly quickly.